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CcpNMR	notebook	

I. Visualizing spectra in CcpNMR 
A. Starting CcpNMR, opening and creating projects 
- In a terminal window, enter the command module load ccpnmr (type the text 

of the command, then hit Enter). This command is specific to this tutorial (the 
CcpNMR environment must be activated in the system booted from USB stick). 

- Then, enter the command analysis. A main menu window opens.  
- Select the Project menu with a left mouse click. A submenu appears.  
- To open an existing project, navigate to the directory containing the project (which 

is itself a directory) and double click on the project directory. 
- Alternatively, you can also navigate to the directory containing the project in the 

terminal and then enter the command analysis <project name>, where 
you replace <project name> with the actual name of the CcpNMR project 
directory. 

- To create a new project, click New in the Project menu. Then, enter the name of 
your project. 

B. Example: Create a project containing the 15N-HSQC of ubiquitin 
Load the protein sequence 

- Click New in the Project menu. Then, enter 'ubi_test' as the name of your project. 
- In the CcpNMR main menu, click Molecule > Molecules, then Add Sequence and 

Read File. 
- Load the ubiquitin sequence file 'ubi.seq' (in the folder 'Database_spectres/ 

petite_proteine_structuree'). 
- Click Tidy and Add Sequence. 
- Accept all proposed answers in the following questions. 
Load the 15N-HSQC spectrum 

- Select Experiment > Open Spectra. 
- At the top of the new window that opens, change File format (pull-down menu at 

the top) to NMRPipe. Make sure that File type in the center of the window shows 
the NMRPipe (*.ft*) option. 

- Navigate to the folder 'Database_spectres/petite_proteine_structuree/ubi' and 
select the file 'hsqc_ubi.ft2'. 

- Approve the selection by clicking Open Spectrum, then click on Commit in the 
window that opens (after checking axis calibrations). 

- The 15N-HSQC spectrum will be by default associated to Expt_1. 
- In the following window, you can define the spectrum as a '15N HSQC/HMQC' by 

double clicking on the empty field in the Type Synonym column of the first line in 
the (otherwise empty) list, and selecting '15N HSQC/HMQC'. As External Name, 
enter for example ‘15NHSQC’. Then, click Close – All Done. 

- The HSQC spectrum then opens in a new window (by default window 1).  
Save the project 
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- We will use this spectrum later in step III.B of this CcpNMR tutorial, so either 
keep it open or save it now. 

- To save a project, in the CcpNMR main menu, go to Project > Save as and save 
the project (a new project directory will be created) in a location that you can write 
to. 

II.  Navigating spectra and windows 
A. Overview - Shortcuts 

Spectrum Manipulations 
Page Up Zoom out 
Page 
Down Zoom in 

Up Move spectrum up within the window 

Down Move spectrum down within the 
window 

Left Move spectrum left within the window 

Right Move spectrum right within the 
window 

Home Zoom the slice range down 
End Zoom the slice range up 
c Centre the window where the mouse is 
j Scroll left orthogonally 
k Scroll right orthogonally 
i Increase the number of contours 
o Decrease the number of contours 
e Raise the countour level 
r Lower the contour level 
 
Marks and Rulers 
h Create a horizontal ruler 
v Create a vertical ruler 
m Create a mark 

n Clear all marks and rulers 
 
Pop-Ups 
a Bring up the Assignment pop-up 
b Bring up the Browse Atoms pop-up 
u Bring up the right-click Mouse Menu 
s Show the selected peaks in a pop-up table 
 
Peaks 
p Move selected peak 

P Automatically centre the peaks on the closest 
maxima/minima 

q Move peak label 

w Automatically set the peak label positions such 
that they do not overlap 

W Reset the peak labels to their original positions 
l Unite peak positions 
s Show the selected peaks in a pop-up table 
 
Other 
S Save project 

 
 

B. Switch spectra on/off 
- In the top left hand corner of each spectrum window, there is a button Spectra. 

Click on it to show a list of all open spectra in the current project that can be 
displayed in this window. Each spectrum can be toggled on/off using its button in 
this list, so that you can display as many or as few spectra in each window as you 
wish. 

- To open further windows, click on Window in the CcpNMR main menu. At the 
bottom of the pull-down menu that opens is a list of windows contained in the 
current project; clicking on any of them will open the corresponding window 
(which might have been closed / minimized and thus invisible). New windows, if 
needed, can be defined via New Window in the Window menu. 
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C. Zooming / moving around in spectra 
There are several ways to zoom and move around in the spectra (note that the mouse-
based ones may not work in Windows!): 

- To zoom, rotate the mouse wheel; or middle-click the mouse while holding down 
Shift and drag the mouse; or use the Page Up / Page Down keys. 

- Move to a different part of the spectrum by using the scroll bars or simply click on 
the middle mouse button and drag the spectrum. 

- To move through the z-planes of a 3D spectrum, either use the z-plane scroll bar at 
the very bottom of the 3D window – or simply turn the mouse wheel while holding 
down Ctrl. 

- If you want to go to a specific position on the z-axis of a 3D window, simply type 
the ppm value into the box in the bottom left hand corner. 

D. Contours 
- To change contour levels in a spectrum window, click the Contours button at the 

top and then the green up and down arrows appearing below it. Alternatively, you 
can use the keyboard shortcuts ‘e’ and ‘r’. 

- To show negative and/or positive contours, click the ‘Pos/Neg’ button (when the 
Contours button is active). 

- More detailed contour level settings are accessible via the More... button. 

E. Using marks and rulers 
Often it is useful to draw lines through your spectra to check whether two peaks occur 
at the same chemical shift or not. 

- A mark is drawn through all dimensions at the position where it is placed. To draw 
a mark, place the mouse where you want it to be and press 'm'. If you are close to a 
peak, then the mark will automatically be drawn through the peak. 

- Rulers only go through one dimension. To draw a ruler, place the mouse where 
you want it to be and press 'v' for a vertical ruler or 'h' for a horizontal ruler. 

- You can remove all marks and rulers by pressing 'n'. Alternatively, you can right-
click the mouse and go to Markers – here you can place marks and rulers, or you 
can selectively remove only marks or only rulers. 

III. Peak picking 
A. How to pick peaks 
- To identify, label, and assign peaks in spectra, they have to be "picked", i.e. 

marked by a cross. CcpNMR stores information about picked peaks, notably their 
chemical shifts, in a database where it can be accessed for further analysis. 

- The best way to pick peaks is to let the program find the correct peak maximum 
for you. To do this, simply left-click and drag the mouse over a peak (or several 
peaks) while holding down Ctrl and Shift. You can do this both in 2D and 3D 
spectra.  

- Sometimes several peaks are overlapped and it is better to place the peaks 
manually. Simply place the mouse where you want to have your peak and then 
left-click while holding down Ctrl. Alternatively, right-click the mouse and select 
Peak and then Add New Peak. 
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- A peak is selected when a box is drawn around it. To select a peak either click on 
it, or drag the mouse over it. To deselect your peaks just left-click the mouse 
somewhere in a spectrum window. To select several peaks at the same time, drag 
the mouse over several peaks in one go, or keep the Shift button pressed down 
while you select each peak individually. 

- To delete a peak, select it, then press Delete. 

B. Picking the peaks of the ubiquitin 15N-HSQC spectrum 
- In the project 'ubi_test' created under I.B above, go into window 1. 
- Try to select an appropriate contour level in order to visualize only 'real peaks' 

without displaying noise. (Of course, one might not know at this stage what is real 
and what is noise!) 

- In the main menu, go to Peak > Peak Finding. 
- In the tab Find Parameters, check that the option positive only is selected. Only 

positive peaks will be picked. 
- In the tab Region Peak Find, you can adjust the size of the region used for peak 

picking, if needed, to prevent the picking of undesired signals (e. g. water signals 
near 4.7 ppm 1H chemical shift in 15N-HSQC spectra). 

- Click on Find peaks!. Alternatively, left-click and drag across the entire spectrum 
while keeping Ctrl and Shift pressed down. 

- Inspect the quality of peak picking. Check the peak table (main menu: Peak > Peak 
Lists and then the Peak Table tab). 

IV. Specifics for manipulation of [13C,13C] and [13C,15N] solid-
state NMR spectra 

A. Set double cross-hair mouse pointer 
- By default, your mouse will form a single crosshair with one vertical and one 

horizontal line. However, when you have two axes belonging to the same type of 
nucleus (e.g. in a carbon-carbon correlation spectrum), it is really useful to have a 
double crosshair (with two vertical and two horizontal lines) which will trace 
equivalent points on either side of the diagonal.  

- In order to set a double crosshair mouse, go to Window in the main menu, select 
Windows and there the Windows & Axes tab. When you click on a window in the 
upper part of this pop-up, you will see the axes displayed in the lower part. One of 
the columns is titled Panel Type. By default, these are all set to be different, so for 
a 13C-13C window, they will be called C1 and C2. If you set the panel types to be 
the same, then you will obtain a double crosshair mouse. We find it useful to go 
through all windows and make sure that all panel types are C1, N1 or H1 for 13C, 
15N and 1H axes, respectively. This way, you will always see a double crosshair 
mouse in diagonal spectra, and you will always see equivalent mouse crosshair 
lines in all other windows as well. 

B. Identifying sideband peaks 
- Open the project 'ccpnmr_cristaux_b' in the 'ssNMR/cristaux' folder. 
- In the 13C-13C spectra of window 1, diagonal lines are drawn at regular intervals 

from the spectrum diagonal. These indicate the locations of (potential) spinning 
sidebands of the diagonal. These lines are drawn if the MAS spinning speed at 
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which an experiment was recorded is entered in the Experimental Details tab (main 
menu > Experiment > Experiments). You can also use 'v', 'h' and 'm' to draw 
vertical rulers, horizontal rulers or marks, which will be repeated at sideband 
intervals. This is a convenient way to identify whether, for instance, a peak in the 
aromatic region of the spectrum is actually a sideband peak from the carbonyls. If 
marks and rulers are not visible, check Window > Marks and Rulers and set 
mark/ruler color to something other than white. 

- If you have identified a peak as being a sideband peak, you may want to mark it in 
some way, in order to remember that it is a sideband peak. There are two ways to 
do this. Either, right-click, go to Peak and then Set merit and choose 0.0. 
Alternatively, right-click, go to Peak and then Set details – you can then type 
something like "sideband" in the comment box. Now go to the Peak menu of the 
main menu and select Draw Parameters. Make sure that Merit Symbol or Details 
are selected in the Annotation Style tab, depending on which one you opted to use. 
If you are using the Merit Symbol, then go to the Merit Symbols tab and enter a 
symbol such as * or ! into the Poor merit box and click on Set symbols. Now your 
sideband peak should be marked either with a symbol or a comment to remind you 
that it is not a real peak. 

- It is likely that a rather more sophisticated system of properly identifying sideband 
peaks will be introduced some time in the future. But in the meantime, this is a 
reasonably good fix. 

	
 

 


